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Welcome to Global Mapper 

 
Thank you for downloading Global Mapper®, the all-in-one GIS application that everyone can use. 
This remarkable software combines a powerful array of spatial data processing tools with an 
unmatched list of compatible file formats resulting in a program that no GIS professional or map 
enthusiast should be without. 
 
As you begin to explore the wealth of features and functions in Global Mapper, you will quickly learn 
that this is a truly unique software tool. Nowhere else will you find a single application that offers 
the level of data support, digitizing capabilities, spatial analysis, and map creating tools, at a cost 
that will ensure a rapid return on your investment. 
 
At Blue Marble Geographics, we are committed to ensuring our customers are provided with the 
information and tools necessary to effectively use the software they have purchased. To that end, 
we are pleased to offer a number of resources to help you get up and running in no time.  
 
This Getting Started Guide is designed to assist you with the basic operation of Global Mapper and 
to help you understand some of the commonly used features and functions. For a complete guide to 
all the software’s capabilities, click the Help menu and choose Help… or click the F1 key on your 
keyboard. 
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Installation and Registration 

Installing Global Mapper 
The current version of Global Mapper is freely downloadable from the following web page: 
www.bluemarblegeo.com/global-mapper/product/download_complete.php 
 
Depending on your computer’s operating system, you can choose either the 32-bit or 64-bit version. 
The latter will allow you to take full advantage of the extra memory available for 64-bit applications 
and will improve the performance of the software. To install Global Mapper, simply double-click or 
run the downloaded executable file (global_mapper_setup.exe or global_mapper_setup_64bit.exe). 
Installation will take no more than a couple of minutes. 
 

Registering Global Mapper 
The first time you launch Global Mapper, you will see the Register Global Mapper window. The 

option you select will determine the level of functionality available to you when you run the 

software. 

- Order ID from Recent Purchase 

Enter your order number and Global Mapper will be automatically 

registered, unlocking the full functionality of the software.  This 

procedure requires an internet connection. 

- Connect to a Network License Server 

If your company has chosen to deploy Global Mapper using the 

convenient network licensing option, you can connect to the 

appropriate server to register your version of Global Mapper 

- Select a License File (.lic) File Provided via Email 

If you work in an offline environment, you may request a License File 

to manually register Global Mapper. If this is the case, you will be 

prompted to browse to the location where you saved this file, after 

which, you will have full access to the software. To request a .lic file, 

please contact Blue Marble at authorize@bluemarblegeo.com 

- Request a 2-Week Trial License 

To evaluate Global Mapper, you can request a 14-day trial license that will allow you to test all 

of its features and functions. During this time, you will be limited to two exports for each file 

type (vector, raster, and elevation). 

Activating Optional Modules or Extensions 
With the release of Global Mapper 15, additional functionality can be added to the software through 

preconfigured modules or third party extensions. To activate these add-on components, click the 

Help menu and choose Module/Extension License Manager. Modules require the purchase of the 

appropriate license and include Global Energy Mapper (for more information, see page 21) and the 

LiDAR module (for more information, see page 16). Extensions are typically developed and 

registered by third party developers. Two preconfigured extensions are installed with Global 

Mapper: the Overview Map extension and the COAST extension for analyzing the financial impact of 

coastal flooding.  

http://www.bluemarblegeo.com/global-mapper/product/download_complete.php
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Navigating the Interface 

Software Layout 
Global Mapper’s user interface has been designed to provide easy and intuitive access to all of the 
software’s features and functions. The key elements of the interface are the menus, the toolbar, 
and, of course, the map window itself. A variety of dialog boxes and floating windows provide access 
to additional tools or more advanced functionality. 
  

The Title Bar displays information 
about the version of Global 

Mapper and the name of the 
current Workspace. For more 

information, see page 8. 

The Toolbar offers a 
convenient way to select a 

tool, apply a specific function, 
or change a setting. For more 

information, see page 5. 

Menus provide access to 
most of Global Mapper’s  

core functionality. 
For more information,  

see page 4. 

The Favorites List provides 
easy access a customizable list 
of frequently-used tools. For 

more information, see page 5. 

The Scale Bar and other 
display features are 
managed using the 

Map Layout function. 

Information about a 
selected feature as well 
the coordinates of the 
cursor are displayed on 

the Status Bar. 

The Overlay Control 
Center lists all loaded 

layers and allows certain 
settings to be applied to 

these layers. 

The Digitizer Right-Click Menu 
offers an extensive collection of 

tools for creating or editing 
features on the map.  

For more information,  
see page 12. 
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Navigating the Interface (continued) 

Menus 
The menus in Global Mapper are intuitively organized by function and offer access to all of the 
features and functions in the application. Note that, as with other software titles, there are often 
many ways to access a particular function in Global Mapper. For example the action of importing a 
layer can be performed using the Open Data File option in the File menu; the Open Data File button 
in the toolbar; or by using the Ctrl+O keyboard shortcut. How you chose to perform this and other 
commonly used functions comes down to your personal preference. 
 
The following summarizes the primary function of each menu: 

 
- File 

The File menu contains all of the options for importing, exporting and saving data. It also 
includes a list of recently imported files, providing convenient access to frequently used layers.  

- Edit 
The singular function of the Edit menu is to enable the copying and pasting of features and to 
control the associated options. 

- View 
The View menu includes an array of settings for configuring the appearance of the interface and 
of the map itself. There are also options for manually adjusting the zoom level and for saving 
and restoring a specific map view. 

- Tools 
As its name implies, the Tools menu contains a 
selection of tools that are used to interact with 
features on the map. Based on what is selected, the 
function of the cursor on the map will change. This 
menu also provides access to certain other dialog 
boxes such as the Overlay Control Center and the Map 
Layout options. 

- Analysis 
New in version 14, the Analysis menu consolidates 
many of the analysis functions into a convenient single 
list. With an elevation layer loaded, you can perform a 
variety of terrain analysis processes, such as 
generating contours and delineating watersheds. 

- Search 
The Search menu offers several options for querying or 
editing feature attributes. It also includes an address 
search function that includes geocoding capability. 

- GPS 
When a compatible GPS receiver is connected to your computer, your position can be 
represented by a symbol on the map. The GPS menu controls the configuration and interaction 
between Global Mapper and your GPS device.  

- Help 
The Help menu provides a single point of access for the various help options and other 
resources that are available for Global Mapper. For more information, see page 22. 
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Navigating the Interface (continued) 

The Toolbar 
The various buttons on Global Mapper’s toolbar offer the most convenient way to select a tool, to open 
certain dialog boxes, or to switch between one function and another. If necessary, button groups, 
denoted by a dividing line, can be removed from the toolbar using the Toolbars option in the View 
menu, or can be undocked or moved to another position in the toolbar.  
 
The following are the key buttons in the toolbar: 
 
 
  

The Open Data Files button is 
used to initiate the import of data 

in any supported format. For 
more information, see page 9. 

 

The Download Online Data button 
offers access to a wealth of online data 

sources such as WMS and WFS. For 
more information, see page 11. 

 

The Overlay Control Center button 
activates the dialog box for 
managing loaded data layers. For 
more information, see page 7. 
 

The Save button saves the 
status of all imported data, 

digitized features and 
configuration settings to a 

Workspace file. 

The Map Layout button is used 
to add cartographic features such 

as a scale bar, legend, and a 
compass rose to the map. 

 

The Configuration button opens 
the Configuration window that is 
used to establish numerous 
settings in the software. For 
more information, see page 6. 
 

The Pan Tool allows the map to 
be grabbed and dragged to 
recenter on a new location. 

 

The Feature Info Tool is used 
to view attribute data and 
other information when a 

feature is selected. 
 

The View Shed Tool is used to select a 
point on the map from which to 
perform a view shed analysis. 
 

The Measure Tool temporarily 
changes the cursor into a 

measuring device that can be used 
to determine length and area. 

 

The 3D Path Profile Tool is 
used to create a line feature 
on a terrain surface for the 

purpose of generating a 
cross-sectional profile. 

 

The Image Swipe Tool allows a raster 
layer to temporarily uncovered to 
reveal any underlying layers. 

The Zoom Tool is used to zoom to 
a desired location on the map. 

 

The Digitizer Tool controls the 
creation and editing of vector 
features (lines, points, and 
areas) on the map. For more 
information, see page 12. 
 

The Run Favorite 
button initiates the 
function selected in 
the Favorites List. 

The customizable Favorites 
List provides easy access to 

frequently used tools and 
allows keyboard shortcuts 
to be assigned to selected 

functions. 
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Setting Preferences 

The Configuration Dialog Box 
The Configuration dialog box can be opened from the Tools menu or by clicking the Configuration 
button in the toolbar. Organized in a series of tabs, it provides a single location for establishing 
personal settings and preferences that control many of the features and functions of the software. 
 
The following summarizes the settings available in each tab: 
 
- General 

The General tab options include the establishment of 
default units of measurement, map grid display, coordinate 
format, as well as numerous miscellaneous settings. 

- Vector Display 
The function of the Vector Display tab is to control the 
appearance of point, line, and area features on the map. 
Specific options include filtering data types, adjusting the 
layer display order, rendering deleted features, and 
enabling or disabling snapping when drawing new features. 

- Area Styles 
The Area Styles tab is used to manage the feature types 
that can be assigned to area features or polygons. Assigning 
a feature type to an area or areas will automatically adjust 
the appearance and the availability of attribute fields. 

- Line Styles 
The Line Styles tab is used to edit or create line types that 
control the visual characteristics and attribute fields for 
linear features. 

- Point Styles 
The Point Styles tab contains a customizable list of available point or symbol types with 
accompanying attributes. If necessary, new types can be added and custom symbols can be 
created from imported graphic files. 

- Vertical Options 
The Vertical Options tab offers a number of settings that control the display of elevation or 
terrain layers. These settings include the selection of a shader pattern, customization of the hill 
shading or shadow display, and the rendering of a simulated water level at a defined height. 

- Shader Options 
The Shader Options tab controls the visual display of several preconfigured elevation and slope 
shader patterns and allows new patterns to be created. 

- Projection 
The Projection tab is used to alter the coordinate reference information for both onscreen 
display and export of data. Numerous preconfigured projection and datum options are available 
and custom systems can be added as needed. This is the feature to use if you need to reproject 
a layer from one system to another before exporting. 

 
While the Configuration dialog box offers access to most of Global Mapper’s preferences and settings 
options, many other components of the software contain feature-specific settings that are established 
when performing that function. For example, when exporting a file in a particular format, many of the 
preferences associated with the exported file are set in the Export Options dialog box.  
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Layer and File Management 

The Overlay Control Center 
The Overlay Control Center is Global Mapper’s layer 
management tool. It can be opened from the Tools 
menu, by clicking the Open Control Center button in 
the Toolbar, or by using the keyboard shortcut Alt+C. 
Unlike most other dialog boxes, the Overlay Control 
Center can remain open while using other tools in 
the software. Many Global Mapper users prefer to 
keep this dialog box visible as it is frequently needed 
to hide or show specific layers, to adjust certain 
charcteristics of the layers, or to perform other 
layer-specific functions. 
 
There are two ways in which a layer or overlay can be removed from the map display: the adjacent 
box in the Overlay Control Center can be unchecked or the selected layer can be removed 
completely by clicking the Close Overlay button. Using the uncheck option, the layer is retained and 
can be simply checked on again when needed. Closing an overlay permanently removes it and any 
unsaved edits or created features will be lost. 
 
The key functional components of the Overlay Control Center are the Options button, which opens 
the Options dialog box that is used to adjust certain settings pertaining to a layer, and the list of 
tools or commands that is displayed after right-clicking on a layer. In both cases, the available 
functions and tools apply only to the selected layer and will vary depending on the type of data 
(raster, vector, or elevation) contained within this layer.  
 

The Options Dialog Box 
The tabs in the Options dialog box differ depending on the type of data 
contained in the selected layer: 
 
- Vector Options 

The primary functions of the Vector Options dialog box include 
managing the display of labels; assigning features to a feature-type 
category; and adjusting the display characteristics of the features in 
the layer (fill pattern, symbol style, etc.). 

- Raster Options 
The Raster Options dialog box includes tools for establishing 
transparency; adjusting color balance, contrast, etc.; and cropping 
an image to a defined area. 

- Elevation Options 
The available Elevation Options include tools for offsetting elevation 
values in the layer and for defining the range of visible elevations. 

 
Each of the Options dialog boxes includes a Projection tab, which is used to reinterpret the 
coordinate values associated with the selected layer. Adjusting these projection parameters will 
result in the contents of the layer being physically moved to a new location and should only be 
performed when you know the original coordinate settings were incorrect. To simply reproject your 
map, use the Projection tab in the Configuration dialog box (for more information, see page 6).  



8 
Copyright Blue Marble Geographics 2013 

Layer and File Management (continued) 

Saving Your Workspace 
The workspace is the core file management component of Global Mapper. It allows you to store 
information about the layers that are displayed on the map as well as any settings or configuration 
that have been applied to these layers. At its most basic level, a workspace is a file (*.gmw) that 
records a snapshot of your current map view. 
 
To save your workspace, click the Save button in the toolbar or 
click the File menu and select Save Workspace... If a workspace 
was not previously saved, you will be prompted to name and 
choose a location for the file. You can also create a duplicate of 
an existing workspace by using the File > Save Workspace As… 
option. This function is useful for establishing a workspace template, possibly containing all possible 
layers or covering the full extent of your area of interest. Any workspaces created from this 
template using the Save Workspace As… command will inherit all of the layers and settings from the 
original and can then be individually modified to reflect the requirements of a particular project or 
jobsite. 
 

Working with Imported Layers 
An important consideration when working with workspace files is that they do not actually contain 
the map data from any files that are imported. Instead, the workspace records the path to the 
original file location as well as any edits or configuration that has been applied to this layer. If the 
path to the file location is broken, such as when you disconnect from your local network or when 
the file is deleted or moved to a new location, the workspace will not load correctly and an error 
message will be displayed. For this reason, workspace files should typically not be shared with other 
Global Mapper users, based on the assumption that the path to the included data is unique to the 
original computer. 
 

Working with Digitized Features 
Points, lines, and area features that are created using Global Mapper’s Digitizer tools are stored 
directly in the workspace file. Modifications or additions made to any imported data are similarly 
archived internally within the software and are only applied to the original external data using the 
export function. 

 

Global Mapper Package Files 
An efficient way to share data among Global Mapper users is to create a Global 
Mapper Package file (.gmp). Unlike the aforementioned workspace format , a 
package file contains all of the map data from any previously imported layers and it 
retains all of the configuration settings and edits that where applied to these layers. 
A single Global Mapper package file can contain data in any format (raster, vector, 
and/or elevation) and as such, it provides an extremely efficient tool for exchanging maps and 
spatial data among Global Mapper users. 
 
Global Mapper package files also offer a simple way to create backups of important datasets that 
can easily be reimported in the event of a loss of the original data or hardware failure. 
 
For more information on exporting, see page 19. 
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Importing Data 

Supported Data Formats 
One of the defining characteristics of Global Mapper is the volume and variety of file formats that 
can be imported into the software. In the current version, over 200 file-types are supported, 
including all common spatial formats, such as ESRI shapefiles, KML files, MrSID imagery and LiDAR 
elevation files. Virtually any type of geospatial data is supported in Global Mapper, including raster, 
vector, 2D, and 3D, whether referenced or not. If Global Mapper doesn’t support your data, let us 
know and Blue Marble developers will do their best to add it as a supported format. A list of the 
currently supported formats is available in the Global Mapper section of bluemarblegeo.com 
 

Importing Vector, Raster, and Elevation Layers 
There are several ways to import data into Global Mapper. You can use the File > Open Data File(s) 
command; you can click the Open Data File(s) button in the toolbar; or you can use the Ctrl+O 
keyboard shortcut. In each case, you will be prompted to browse to the required file to initiate the 
import process. 
 
Aside from text files, as noted below, all vector, raster, and elevation formats are imported using the 
same dialog box and the same procedure. Global Mapper is able to differentiate the different 
formats and automatically assigns each to the appropriate overlay type. If required, you may be 
asked to define the coordinate parameters, to verify the data format for files with unconventional 
suffixes, or to manual rectify the file if there is no inherent geographic reference information. For 
more information on the rectification process, see page 10. 
 
When importing, it is possible to select multiple files by holding down the Ctrl or Shift key while 
selecting the required files in the Open dialog box. Alternatively, you can open all compatible files in 
a specified folder or directory tree using the File>Open All Files in a Directory Tree command. 
 
Finally, and perhaps most conveniently, you can simply drag and drop a compatible file onto the 
Global Mapper window to automatically initiate the import process. 

 

Importing Text Files 
Text files containing a list of coordinate 
values can be imported into Global 
Mapper and used to create points, 
lines, or area features. To initiate the 
text file import process, use the File > 
Import Generic ASCII Text File(s) 
command. 
 
After selecting the required file, you 
will be prompted to assign certain 
parameters for the imported file such 
as the order and format of the 
coordinate values, the number of 
header rows in the file, and whether or 
not to import accompanying 
attributes. 
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Importing Data (continued) 

Geo-rectifying Image Files 
Global Mapper’s Image Rectifier function provides a powerful tool for creating a geographically 
referenced raster layer from virtually any image file or PDF. The procedure usually involves 
identifying visible features in the imported image and tagging each of these with their 
corresponding coordinates. 
 
To import an image, you can 
either use the standard File > 
Open (Ctrl +O) command or File 
> Rectify (Georeference) 
Imagery. If you choose the latter, 
you have the option to directly 
export the resulting raster file 
after the required control points 
have been assigned. 
 
After selecting the file to be 
imported, the Image Rectifier 
dialog box is displayed showing 
an overview of the image; a 
zoomed view of the image in 
which the control points can be 
precisely placed; and a zoomable 
view of the current map. To 
begin the process, click an 
identifiable point on the image, click the corresponding point in the adjacent map, and click the Add 
Point to List button. Repeat this process for several additional points spaced as far apart as possible. 
Alternatively, you can manually type the X and Y pixel values from the image and/or type the 
corresponding coordinate values derived from surveyed ground control points. 
 
After all of the control points have been assigned, click the OK button to create a new raster layer. 
To correct any errant registration points, select the layer in the Overlay Control Center, right-click 
and choose RECTIFY – Modify Layer Position/Projection. 

 

Working with Spatial Databases 
As an alternative to importing files, advanced users can establish a direct connection to an existing 
spatial database, which allows Global Mapper to both read and write vector data directly from the 
database tables. Among the supported database types are ESRI ArcSDE, ESRI File and Personal 
Geodatabases, My SQL Spatial, Oracle Spatial, PostGIS, and Spatialite. The ESRI databases also 
support raster data formats and are only available in the 32-bit version of Global Mapper. 
 
To establish a connection to a spatial database, open the Spatial Database Connection Manager 
(Tools > Connection Manager), click the New button, and enter the required settings. To import data 
from a connected database, click the File menu and choose Open Spatial Database, select the 
database name, click the Open button, and select from the available tables. 
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Accessing Data Online 

Using the Download Online Data Function 
A great way to get started making maps with Global Mapper is to download some of the many free 
online datasets. Numerous government agencies, organizations, and commercial companies provide 
direct streaming access to their spatial data archives though Web Map Service (WMS), Web 
Coverage Service (WCS) and other online protocols and Global Mapper includes preconfigured links 
to many of these servers. 
 
To initiate the download process, click the Download Free Maps/Imagery from Online Sources quick-
start button on the introductory screen or click the Download Online Data button from the toolbar. 
In both cases, the resulting dialog box will list all of the available Data Sources, categorized by type 
or by geographic area.  After expanding a category list, simply select the required data source and 
set the extent of the data to download using the options at the bottom of the window. 
 
On occasion, you may find that the service that you require is not available and you will see an error 
message to that effect. This circumstance may be due to routine system maintenance, excessive 
traffic, or other technical issues. Unfortunately Blue Marble has no control over the availability of 
these online map sources so it is recommended that you save the data to a local file so you do not 
have to continually depend on the streamed service. See below for more information. 
 

Premium Data Sources 
Blue Marble has partnered with several commercial data providers to offer convenient access to 
high-quality imagery and elevation datasets. If you select one of the Premium Content options in the 
Online Data Source dialog box, you will be prompted to enter the appropriate log-in details or data 
access ID number to download the data. Information on subscribing to these services can be 
obtained from the data provider’s web site.  
 

Adding Custom Data Sources 
While Global Mapper includes a number of preloaded maps services, you can also add custom 
online sources if they are available for your area of interest. Many GIS departments now use the 
web as an efficient delivery mechanism for their datasets and Global Mapper allows you to set up a 
direct link to this data. After clicking the Add New Source button in the Online Data dialog box, 
simply enter the appropriate URL to establish this link. 
 

Saving Data for Use Offline 
Because the availability of the streaming data services cannot be guaranteed, it strongly 
recommended that you save a local copy of any online map data. Not only will this ensure that you 
will always have access to the required layers, even when offline, but it will significantly speed up 
the map draw speed when working with this data. 
 
To save downloaded data, click the File menu and select Export > Export Raster/Image Format, 
choose a file format when prompted, and enter the file settings as needed. A good format choice is 
JPEG 2000 (.jp2) as it provides a balance between file size and image quality. Before finalizing the 
export, click the Export Bounds tab in the Export Options dialog box and choose one of the available 
options to limit the geographic extent of the exported file, otherwise you may inadvertently 
generate an extremely large file. Note that saving data will take considerably longer than simply 
displaying it on the map, so be prepared to wait some time for the file to be saved.  
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Using the Digitizer 

The Digitizer Tool 
Arguably the most powerful tool in Global Mapper, the Digitizer allows you to create, delete, edit, 
move, reconfigure, and copy points, lines, and area features on the map. The most frequently used 
digitizer components can be accessed directly from the toolbar at the top of the map window but 
many more tools are available by right-clicking on the map after the Digitizer has been enabled. 
 
When used by itself, the Digitizer is a selection tool. After clicking the Digitizer button in the toolbar, 
the position of the cursor is represented by a crosshair with the word EDIT displayed below, and in 
this mode, points, lines, and area features can be selected in preparation for editing, moving etc. 
Individual features can be selected by simply clicking the feature on the map or multiple features 
can be simultaneously selected by clicking and dragging a box that encompasses the extent of the 
required features or by holding the Ctrl key while selecting multiple individual features. 

 

Drawing Freehand Features 
The following buttons are used to manually create vector features on the map:  
 

Use this tool to create area features or polygons by repeatedly left-clicking on the map. 
Right-click to add the final point, which is automatically connected to the first point. 

 
Regular rectangle areas are created using this tool by left-clicking and dragging your mouse 
to the opposite corner. To create a square, hold the Shift button down while dragging. 
 
The vertex-mode line tool is used to create line features by clicking at each desired shape 
point on the map. The line is terminated using the right mouse button. 
 
Use the trace-mode line tool to create freehand lines by clicking and holding the left mouse 
button while moving the mouse. 
 
Similar to the rectangle area tool, the rectangle line tool creates squares or rectangles by 
left-clicking and dragging your mouse. In this case, only the perimeter line is drawn. 
 
Point features or text are created by selecting this tool and simply clicking at the required 
location on the map. 

 
When using any of these tools, the completion of the drawing function triggers the Modify Feature Info 
dialog box, in which the name, feature-type, attributes, and target layer are assigned. 
 

Additional Digitizer Buttons 
The Global Mapper toolbar contains a number of additional buttons for activating specialized vector 
creation tools. The CoGo tool is used to create line or area features by entering specific dimensions 
and bearings; the Range Ring tool generates concentric circular area features of a specified 
dimension around a selected point; and the Grid tool is used to create an array of grid tiles of a user-
specified width and height. 
 
Most of the remaining buttons on the Digitizer toolbar are for editing selected vector features and 
will be discussed below. 
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Using the Digitizer (continued) 

Advanced Digitizing Tools 
While most standard vector 
features can be created using 
the previously listed buttons, 
there are a number of 
additional Digitizer tools that 
are accessed by right-clicking on 
the map. These tools are 
organized in submenus by type 
(areas, lines, and points) and 
provide more advanced drawing 
functionality. 
 

Editing Vector Features 
Global Mapper provides tools for editing both the geometry or physical appearance of vector 
objects as well as the attributes or information that is associated with each feature. Edits can be 
applied to features created in Global Mapper or to features from an imported vector layer. Note 
modifications made to an imported layer are not applied to the source file and the layer must be 
exported to apply these updates in the original file format. 
 

Before initiating any editing function, the feature or features 
must be selected with the Digitizer tool as previously 
described. The act of selecting a feature activates several 
additional buttons in the toolbar that offer such options as 
moving, rotating, scaling, and converting features. Additional 
geometric editing options are available by right-clicking on the 
map. 
 
Global Mapper also provides the ability to edit the shape and 
size of individual lines or area features by adding, moving, or 
deleting vertices or shape points. To enable this function, 
make sure the option to display vertices for selected objects 
(right-click > Options) is enabled. Vertices can then be selected 
with the Digitizer tool and, using the right-click > Vertex 
Editing function, can be modified in several ways. 

 
To restore the original geometric shape or position of a feature, select it with the Digitizer tool and 
choose Move/Reshape Feature(s) > Restore Original Shape of Selected Features. 
 

Deleting Features 
The easiest way to delete a feature in Global Mapper is to select it with the Digitizer tool and use the 
Delete key on your keyboard. Although the feature will be removed from view, it is not permanently 
erased and can be easily recovered if necessary. Using the keyboard shortcut Ctrl+Z immediately 
after deleting the feature will undo the deletion. Alternatively, you can toggle the display of all 
deleted features using the keyboard shortcut Ctrl+Shift+D and, using the Digitizer tool, right-click 
and choose the Undelete option.  
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Working with Attributes 

The Modify Feature Info Dialog Box 
The Modify Feature Info dialog box appears whenever a 
new feature is created or when the right-click > EDIT 
option is chosen after a feature has been selected with 
the Digitizer tool. This dialog box offers several tools for 
establishing the style settings of the features and for 
adding or editing attributes either individually or 
collectively. 
 
The Feature Type dropdown list provides the means to 
assign the selected feature to a preformatted 
classification, which automatically determines the visual 
characteristics as well as the attribute fields that are 
associated with this type. 
 
Attributes can also be manually added or edited for 
selected features using the appropriate buttons at the 
bottom of the Modify Feature Info dialog box. 
 

Advanced Attribute Options 
Global Mapper provides several options for automatically creating or updating attributes. After 
selecting a feature or features on the map with the Digitizer tool, the right-click menu offers an 
Attributes/Style Functions submenu that can be used to automatically assign attributes using a 
variety of criteria. For instance, with an underlying elevation layer, you can assign elevation and 
slope values to selected features or you can add an attribute with a count of the number or point 
features inside a selected area. 
 

Joining and Calculating Attributes 
The join process in Global Mapper allows external data to be assigned to the appropriate features in 
an existing layer for the purpose of creating additional attribute fields. Before beginning this 
procedure, it is essential that the each feature has an existing attribute that matches a 
corresponding value in the data being joined. The join can be based on a one-to-one match, where 
each entry in the imported data matches just one feature on the map, or it can be based on a one-
to-many approach, where an individual record in the data being joined is assigned to several 
features on the map. 
 
To initiate the join process, right-click on the target layer in the Overlay Control Center and choose 
JOIN TABLE. Supported formats for the external tabular data include .txt, .csv, and dbf. 

 
The attribute calculation function, which is also accessed 
by right-clicking on the layer in the Overlay Control 
Center, is used to create a new attribute field by 
applying a calculation to an existing attribute. 
Calculation options include standard numeric 
operations, such as add and multiply, and can use a fixed 
value or the value in a second field for the calculation.  
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Using the 3D Functionality 

Working with 3D Data 
In order to utilize Global Mapper’s 3D functionality, the data with which you are working, must have 
an inherent elevation or height value. Both vector features and appropriately formatted raster 
layers can include this “Z” value and can be modeled in a three-dimensional perspective. 
 
The most common application for 3D data is to generate a terrain surface, which is the basis of 
many of Global Mapper’s analytical functions, such as watershed delineation and flood level 
modeling. A height value can also be applied to a vector feature or to individual vertices that 
comprise a vector feature, which allows the feature to be extruded from a terrain surface. 
 

Where to Find 3D Data 
As with the standard raster and vector data formats, there are numerous sources of 3D or elevation 
data. Global Mapper’s Download Online Data function provides several preformatted datasets that 
can be downloaded free of charge or through a subscription to one of the listed data providers. 
Global Mapper also supports dozens of preexisting elevation formats, such as DEM and Arc/Info Grid 
files that are imported using the normal File > Import process. Simple text files that include 
elevation values along with coordinates can be imported using the File > Import Generic ASCII Text 
File(s) command and can be gridded to create an elevation layer. Finally LiDAR (Light Detection and 
Ranging) data can be imported and processed to create a high-resolution surface model. For more 
information on working with LiDAR in Global Mapper, see page 16. 
 

Creating a Terrain Map from 3D Vector Features 
The process of generating a raster elevation layer from an 
array of vector features that contain an elevation value 
involves gridding the data. This procedure typically follows 
the import of an XYZ text file or LiDAR file, but it can also be 
performed using other vector files such as contours. To 
create an elevation grid from a selected layer, right-click on 
the layer in the Overlay Control Center and choose GRID or, 
if gridding several layers, choose Create Elevation Grid from 
3D Vector Data from the Analysis menu. In both cases, the 
Elevation Grid Creation Options dialog box will appear, 
which offers a number of options for configuring the 
gridding process. 
 

3D Options and Preferences 
By default an elevation layer will be displayed using the 
multi-colored Atlas Shader, although there are several 
additional options in the Shader dropdown list in the 
toolbar. A simulated hill shade or shadow effect will also be 
applied to accentuate variations in the terrain. This can be 
disabled using the Hill Shade button in the toolbar. 
 
Additional 3D options can be established in the 
Configuration dialog box. For more information, see page 6. 
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Using the 3D Functionality (continued) 

Visualizing the Map as a 3D Model 
A supplementary map window in Global Mapper provides the means to view any data with a height 
or elevation value as a three-dimensional model. 
This window is opened using the Show 3D View 
button in the toolbar. 
 
Many of the same zooming and panning 
functions that are used in the 2D map view are 
also available in the 3D window. Additional tools 
allow the vertical exaggeration to be increased, 
the perspective to be changed to ground level, 
and water inundation to be simulated. The 3D 
window also includes a Save function that allows 
the current 3D view to be saved as an image. 
 

Working with LiDAR Data 
A rapidly emerging source of data in the GIS field, LiDAR (Light Detecting and Ranging) data provides 
the raw material for creating highly accurate terrain surfaces or other elevation-derived layers. In its 
native format, LiDAR is a series of closely-spaced points, each of which contains precise coordinates, 
an elevation, a classification that denotes the type of feature that the point represents (ground, 
vegetation, building, etc.), and several additional attributes. Recent developments in Global Mapper 
have expanded support for both the standard LiDAR files (.las) as well as the compressed version of 
the format (.laz). An optional LiDAR module is available that offers advanced LiDAR processing tools 
for more information or to purchase the LiDAR module, visit the Blue Marble web site. 

 
LiDAR data is imported using the 
standard import procedure (Ctrl+O) 
however the subsequent import options 
dialog box is unique to this format. In 
this window, the data can be filtered, 
sampled, and if required, can be directly 
gridded, avoiding the need to render the 
point data. 
 
If the point cloud itself is imported, the 
points will inherit the colors of the 
currently selected shader and will reflect 
the elevation value if no actual color 

values have been assigned to each point. Using the layer’s options dialog box, the color of the points 
can be changed to represent other variables such as classification or intensity. Also unique to this 
format is the Edit function, which is accessed by right-clicking after selecting one or more of the 
LiDAR points on the map. In this dialog box, the point’s classification can be edited and other 
attributes modified. 
 
Creating a terrain surface from loaded LiDAR data involves using Global Mapper’s standard gridding 
tool (for more information, see page 15) and using the resulting elevation layer, any of the 3D 
analysis processes can be performed with a high level of precision. 
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Using the 3D Functionality (continued) 

3D Analysis Functions 
Global Mapper offers a number of analysis tools that utilize loaded elevation or terrain layers. 
Unless noted, these tools are accessed from the Analysis menu: 
 
- Watershed Modeling 

This tool is used to delineate the potential for the 
terrain to support the flow of water using linear 
features to represent stream channels and area 
features to outline watersheds or catchment areas.  

- Path Profile/Line-of-Site 
A Path Profile is a cross-sectional view of the terrain as 
represented by a line feature. The Line-of-Site analysis, 
which will only work with a single segment line, shows 
where obstructions impede the view or transmission 
path from one end of the line to the other. 

- View shed Analysis 
The view shed analysis tool outlines which areas are 
visible or are within the broadcast range of defined 
location. Options such as azimuth range, distance, and height of the point of origin can be 
customized in the view shed analysis setup dialog box. 

- Water Level Rise/Flood Simulation 
Based on a selected area or on actual sea level, the Water Level Rise/Flooding tool outlines 
those areas that will be impacted by a specified increase in water level. 

- Generating Contours 
The creation of contour 
lines is one of the most 
common uses for elevation 
data in Global Mapper. The 
Contour Generation 
Options dialog box allows 
the contour interval to be 
established, supplementary 
areas features to be created, and other settings to be applied. 

- Calculating Volume Between Surfaces 
With two overlapping elevation layers loaded, such as a surface layer and a subsurface bedding 
plane, this straightforward tool calculates the volume of material between the two. 

- Comparing/Combing Terrain Surfaces 
This tool creates a new elevation layer from an operation or calculation applied to the elevation 
values in two overlapping layers. Operators include subtraction, average and maximum. 

- Cut and Fill Calculation 
Available as a right-click option when either a line or area feature has been selected with the 
Digitizer, the Cut and Fill calculation tool determines the volume of material that will need to be 
removed and/or added to create an artificially flattened surface. 

 
For more information or specific instructions on the use of these analysis tools, refer to the help 
documentation that is accessible in the Help menu in the software. 
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Using the 3D Functionality (continued) 

Assigning Height or Depth to Vector Features 
Any point, line, or area feature can have a z value associated with it, which allows it to be modeled 
in a 3D environment relative to other vector features or to a loaded terrain surface. 
 
When importing a vector layer, Global Mapper will automatically look for an existing vertical 
attribute, such height or elevation and use that as the z value. To manually assign a z value, simply 
add a new attribute to the required feature or features and type the elevation, height, or depth. To 
make sure Global Mapper recognizes this attribute as a z value, open the Options dialog box for the 
layer in the Overlay Control Center and choose the appropriate attribute field from the Get  
‘Elevations’ from Attribute Value dropdown list. 
 
It is also possible to add a different z value 
to each vertex that comprises a line or area 
feature. This procedure is initiated by 
clicking the Vertices button in the Modify 
Feature Info dialog box for a selected 
feature. If an elevation value does not 
already exist for each listed vertex, click the 
Add Elevs button and update each 
individual vertex as needed. 
 
When rendered in Global Mapper’s 3D 
window, vector features with an associated 
z value will appear above or below a 
loaded terrain surface layer. The 3D View 
Properties dialog box provides several 
check boxes that are used to control the 
display of these vector features. 
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Exporting and Printing Maps 

General Export Considerations 
Efficient file exporting and map sharing are essential components of any GIS and play a major role in 
the functional makeup of Global Mapper. Just as the software can support a vast array of file 
formats for importing, similarly hundreds of file-types can be exporting ensuring Global Mapper’s 
interoperability with countless third-party applications. 
 
When exporting data from Global Mapper, there are several issues and factors that need to be 
taken into account: 
- All compatible layers and/or visible features will be exported by default. In other words, Global 

Mapper will create a single file for all layers by merging multiple layers into one file. In order to 
export the contents of a specific layer, it will first be necessary to deselect the unrequired layers 
in the Overlay Control Center. 

- There is no automated process for saving edits or additions to an imported file. In order to save 
changes to the source file, you need to export the layer in the same format and overwrite the 
original file. 

- The projection and coordinate settings for any exported data are established in the Projection 
tab of the Configuration dialog box (for more information, see page 6). Regardless of the 
projection parameters of each imported layer, this global projection will be assigned to all 
exports. 

- Each export format’s options dialog box has a set of format-specific settings that are applied to 
the file being exported. Common to all formats are an Export Bounds option, that can be used to 
limit the geographic extent of the data being exported, and a Gridding or Tiling option that can 
be used to break up a single large file into several smaller files. 
 

Exporting Global Mapper Package Files 
When sharing data with other users of Global Mapper, the Global 
Mapper Package format is the preferred choice. This proprietary 
format supports all compatible data-types and allows multiple 
layers to be simultaneously transferred in a single compressed 
file. When imported, the Global Mapper package file will recreate 
the layer structure of the original data. 
 
Global Mapper package files can also be employed as a means for 
backing up critical datasets. This ensures that the data can be 
effectively restored in the event of a loss of the original data or 
hardware failure. To create a package file, click the File menu and 
select Export > Export Global Mapper Package File… 
 

Exporting Vector, Raster, and Elevation Layers 
Unlike Global Mapper’s import process in which a single Open 
command is used to access all compatible data, exporting 
requires the selection of a data type (vector, raster, or elevation) 
and subsequently a specific file format. The Export submenu 
under the File menu offers these three options. The selection of a 
format for the exported data will depend on the intended use of 
the resulting file and its compatibility with the third party 
software into which it will be imported. 
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Exporting and Printing Maps (continued) 

Exporting to a Spatial Database 
In the same way that Global Mapper provides a streamlined way to import data from a spatial 
database, any loaded data, regardless of its origin, can be written out to any of the supported 
database formats. As when exporting data in file format, the Export submenu provides three 
database export options: raster, vector, and elevation. For more information on establishing a 
connection to a spatial database, see page 10. 
 

Exporting Web-Ready Files 
Global Mapper offers several options for creating web-ready files from any loaded data layers. 
Under the File menu, the Export submenu offers the Export Web Format option that opens a dialog 
box in which the required format can be chosen. Several raster tile options are available including 
Google and Bing Map Tiles. Selecting a tiled format will produce multiple image tiles as well as an 
accompanying HTML file that automatically renders the map display interface, map controls, and 
base map data for the chosen format. 
 
The Export Web Format command also offers the option to create Keyhole Markup Language (KML 
or KMZ) files that can be imported into Google Earth or Google Maps. 
 

Printing the Map 
Before sending a map to a connected printer, Global Mapper offers several page layout options that 
can be used to add cartographic elements such as a title, legend, and scale bar to the map. 
The Map Layout button in the toolbar provides access to the Page Layout Setup dialog box. 
Additionally, the File > Open Data File at Fixed Screen Location… command allows any 
supported image file, such as a company logo, to be placed a specified location within the page 
layout. 
 
In the File menu, the Print Preview command displays a low resolution view of the map to be 
printed allowing the layout to be modified if needed. The Print… command will send the map to the 
selected printer based on the Print Setup settings (page size, orientation, etc.) that were previously 
established. 
 

Creating a Geospatial PDF 
Capturing a map view as a Portable Document Format (PDF) allows the map to be shared with 
virtually anyone, regardless of their computer’s operating system. Global Mapper’s PDF export 
function also retains the inherent layering structure and geographic referencing information so that 
the map viewer can turn on and off layers as needed, can see the coordinates when their cursor is 
moved over the map, and can perform simple cartographic functions such as measuring distances. 
 
Exporting a PDF is similar to sending a map to a printer and includes many of the same setup 
options. To create a PDF, click File > Export > Export PDF File… 
 

Capturing a Screenshot 
Perhaps the simplest way to share a map, the Capture Screen Contents to Image command is an 
available option in the File menu or by using the Shift+C keyboard shortcut. The resulting dialog box 
offers the choice of four common image formats and includes an option to save a projection and/or 
world file that will allow the image to be imported into third party GIS application.  
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Global Energy Mapper Functions 

What is Global Energy Mapper? 
Global Energy Mapper is a parallel version of Global Mapper that has been developed to meet the 
needs of the oil & gas, energy production, and extraction industries. Originally released in 
partnership with Spatial Energy, it includes an enhanced online data (WMS) function providing 
direct access to Spatial on Demand® imagery and other datasets.  GEM offers all of the features and 
functions of the standard version of the software and incorporates several additional tools. 
 

Features and Functions Unique to GEM 
Global Energy Mapper offers a number of supplementary data creation and processing tools: 
 
- The Pad Site Placement Tool 

Designed to streamline the process of digitizing or drawing the same structure at every jobsite, 
the Pad Site Placement Tool offers the means to create a library of frequently-mapped features 
that can be manually placed at the required location. To initiate this procedure, select the 
Digitizer tool, right-click on the map, and choose Insert Pad Site from Library. You will be 
prompted to select from the available templates or to add existing vector files to create your 
own template library. Although designed primarily for oil & gas operations, this tool can be 
readily applied in any situation in 
which the same features are 
drawn at multiple locations. 

- Creating a Flattened Site Plan 
This advanced cut and fill 
calculation and terrain 
modification utility is a 
significantly enhanced version of 
the cut and fill tool that is 
available in the standard version 
of Global Mapper. Accessed from 
the Advanced Feature Creation 
Options submenu after selecting 
an area feature and right-clicking 
on the map, this tool combines the calculation of the optimal cut and fill values with the 
creation of a terrain surface that reflects the calculation parameters. Options include the 
determination of slopes or benches that smoothly integrate the flattened site into the 
surrounding terrain. 

- Placing Oil and Gas Symbols 
GEM includes numerous industry standard oil and gas symbols or icons that can be used to mark 
well locations and that reflect the status of the well. To place a well symbol on the map, simply 
click at the required location with the New Point Feature tool (for more information, see page 
12) and choose from the Oil and Gas symbol options in the Feature Type dropdown list in the 
Modify Feature Info dialog box. 

 

Upgrading to Global Energy Mapper  
Upgrading to Global Energy Mapper requires the registration of the GEM module in the 
Module/Extension License Manager in the File menu. To upgrade your license from the standard 
version of Global Mapper, contact Blue Marble Sales at gmorders@bluemarblegeo.com. 
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Where to Find Help 

Global Mapper Help Documents 
Global Mapper’s searchable help system is automatically 
installed with the software and is accessed from the Help 
menu or by clicking the F1 key. You can either browse 
through the contents section or search for a keyword to 
find information on the function in question. Embedded 
hyperlinks help you navigate between sections and 
provide supplementary information about the selected 
topic. 
 

Online Resources 
- An online version of the complete User’s Manual is available here: 

www.bluemarblegeo.com/knowledgebase/global-mapper/Help_Main.html 
- The content of the various help pages are also available in PDF format: 

www.bluemarblegeo.com/knowledgebase/global-mapper/GlobalMapperHelp.pdf 
- Recordings of the monthly Global Mapper webinar series, which cover a variety of topics in the 

software can be viewed here: www.bluemarblegeo.com/products/previous-webinars.php 
 

The Global Mapper Forum 
The Global Mapper Forum is an active online community of users and experts from a wide variety of 
industries and fields. Forum participants have the opportunity to ask questions, offer tips, and 
participate in discussions about the use of the software and its future development. Many new 
users find browsing through the posted topics to be an invaluable part of their learning experience.  
 
A link to the Global Mapper Forum is available in the software’s Help menu or you can navigate 
directly to the following site: www.globalmapperforum.com. 
 

Training Opportunities 
Both public and company-specific training opportunities are available to help you get the most out 
of the software. The availability of scheduled public classes and information about registering is 
posted here: www.bluemarblegeo.com/solutions/geodesy-training.php 
 
Customized onsite or online classes can also be arranged for individual companies or organizations. 
For information, email training@bluemarblegeo.com. 
 

Global Mapper Support 
After all other self-help options have been tried, on-demand support is available to resolve any 
issues with the installation, registration or performance of the software. All support requests are 
initiated using the preconfigured form on the following web page:  
www.bluemarblegeo.com/support/support.php 

  

http://www.bluemarblegeo.com/knowledgebase/global-mapper/Help_Main.html
http://www.bluemarblegeo.com/knowledgebase/global-mapper/GlobalMapperHelp.pdf
http://www.bluemarblegeo.com/products/previous-webinars.php
http://www.bluemarblegeo.com/solutions/geodesy-training.php
http://www.bluemarblegeo.com/support/support.php
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Useful Keyboard Shortcuts 

General Application 
Open the User Guide ............................................................................................................................ F1 

Display 3D Window ........................................................................................................................ Ctrl+3 

Print ................................................................................................................................................ Ctrl+P 

Alt+X .......................................................................................................................... Exit Global Mapper 

 

File Management 
Open data file (import)  .................................................................................................................. Ctrl+O 

Save the current workspace  ........................................................................................................... Ctrl+S 

Load a workspace .......................................................................................................................... Ctrl+W 

Unload (remove) all layers ............................................................................................................. Ctrl+U 

Copy selected features to the clipboard ........................................................................................ Ctrl+C 

Delete and copy selected features to the clipboard ...................................................................... Ctrl+X 

Paste features from the clipboard to a selected layer ................................................................... Ctrl+V 

Open the Overlay Control Center .....................................................................................................Alt+C 

 

Tools Selection 
Digitizer Tool .................................................................................................................................... Alt+D 

Feature Info Tool .............................................................................................................................. Alt+P 

Measure Tool .................................................................................................................................. Alt+M 

Zoom Tool ......................................................................................................................................... Alt+Z 

 

Zooming and Panning 
Zoom in ................................................................................................................................... Page Down 

Zoom out ..................................................................................................................................... Page Up 

Zoom to full extent of all loaded data ............................................................................................ Home 

Pan the Map (¼ screen increments) ....................................................................................... Arrow Keys 

Pan the Map (Entire screen) .......................................................................................... Ctrl+ Arrow Keys 

 

Digitizer Functions 
Edit the feature under the cursor.................................................................................. Left Double-Click 

Select a feature and automatically enter move mode ........................................................ Alt+Left Click 

Undo last operation ......................................................................................................................... Ctrl+Z 

Cancel the current operation .............................................................................................................. Esc 

Delete the selected feature ............................................................................................................Delete 

Undelete the selected feature ............................................................................................. Shift+Delete 

Temporarily disable snapping when drawing a feature ...................................................... Alt+Left Click 

  

Custom Keyboard Shortcuts 
Additional keyboard shortcuts can be manually assigned using the Favorites dropdown list in the 
toolbar. For more information, see page 5. 
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How do I…? 

How do I register Global Mapper? 
After installing Global Mapper, launch the software and you will see the Register Global Mapper 
widow. If you purchased a license, enter the order number as prompted to unlock the full 
functionality. For more information, see page 2. 
 

How do I reproject a layer? 
Open the Configuration dialog box (Tools > Configure), select the Projection tab and update the 
projection and coordinate parameters as needed. These settings will be applied to all loaded data 
and will be applied to exported layers. 
 

How do I change the background color of the map window? 
Click the View menu and choose Background Color... The selected color will be retained for all future 
Global Mapper sessions. 
 

How to I recover a deleted feature? 
Use the Ctrl+Shift+D keyboard shortcut to toggle the display of deleted features. Select the required 
feature with the Digitizer tool, right-click on the map, and choose Undelete to restore the feature to 
its original state. 
 

How do I add text to the map without an accompanying symbol? 
Select the New Point tool from the toolbar and click at the location of the map where you would like 
to place the text. In the resulting Modify Feature Info dialog box, type the text you would like to add 
in the Name field and choose Text from the Feature Type dropdown list. 
 

How do I save map layers from an online data source for offline use? 
After the required online data is displayed on in the map window, click the File menu and choose 
Export > Export Raster/Image Format. In the Export Options dialog box, make sure the Export 
Bounds settings match the geographic coverage requirements. Leaving the default All Loaded Data 
may result in an extremely large file and increase processing time. After the export process is 
complete, close the connection to the online data in the Overlay Control Center and import the 
previously exported file. 
 

How do I automate data processing tasks in Global Mapper? 
There are several tools that can be employed to streamline certain data processing tasks. In the File 
menu, the Batch Convert/Reproject command can be used to collectively translate multiple files of a 
specific type into another format and/or to reproject the data to another coordinate system. 
Scripting can also be used to automate multiple tasks in a workflow. A script is a simple text file that 
contains a series of commands and associated parameters for importing, processing and exporting 
data. For more information on scripting go to the following web page: 
www.bluemarblegeo.com/knowledgebase/global-mapper/ScriptReference.html 

 

 
 

WWW.BLUEMARBLEGEO.COM 

http://www.bluemarblegeo.com/knowledgebase/global-mapper/ScriptReference.html

